Can't get CSS friendly to work in my project

Feb 3, 2010 at 10:07 AM

Hi,

any chance of some assistance. Probably something very simple but I just can't see it at the moment.

I can get the example version of CSF friendly up and runnning and looking at the source code it works.

However applying this to my existing project I just cant seem to get it to work. I have added the DLL reference and created the App_Browsers and placed CSSFriendlyAdapters.browser in it. To me this appears all that is need. However I have also copied in the javascript folder and contents as well to see if that would help.

Any further suggestions

 

 

Feb 23, 2010 at 7:54 PM

Don feel bad, I have run into the same problem.

I have try to run the demos, but noticed a lot errors ( I am running VS2008 3.5). I think the problems stems fro mthe fact that the code has not been updated for Netframewok 3.5.  This combined that they do not have a straight (or simple way) of incorporating the code (no clear example) could be part of my problems and maybe yours.

I do hope that some reads this post and gives a clearer guidance in how implement it. It appears to be agreat product and others so claims.

 

NeilO

Mar 1, 2010 at 5:05 AM
Edited Mar 1, 2010 at 5:12 AM

http://msdn.microsoft.com/en-us/magazine/cc163543.aspx#S3  hope this helps... the eventual good news is that VS 2010 and ASP.NET 4 automatically renders CSS friendly server controls.  So I hope the web hosters quickly adapt to support .NET 4.0 w/o waiting for months.  What's even better is that a few of Austrailian .NETers developed this template pre-configured to use the CSS Friendly Adapters: http://vsxhtml11templates.codeplex.com/ enjoy!